S2 - Copy, Space, Service Requests - Not able to download or upload files
Incident Report for Eptura Workplace
Postmortem

iOFFICE Detailed Root Cause Analysis – Severity 2 – 10/23/23 

Inability to Download or Upload Files for Copy, Space and Service 

We are truly grateful for your continued support and loyalty. We value your feedback and appreciate your patience as we worked to resolve this incident.  

Description: 

On October 23, 2023, at approximately 12:06pm EDT, internal teams and customers support started to receive reports of issues throughout the iOffice platform and the inability to download or upload files in the Copy, Space and Service modules, causing disruption.   

Type of Event: 

Service Disruption 

 

Services\Modules Impacted: 

Production Environment for Copy, Space, Service  

 

Remediation: 

Internal teams restarted independent services which corrected the issue.  

 

Timeline:  

On October 23, 2023, at approximately 12:06pm EDT, internal teams and customers support started to receive reports of issues throughout the iOffice platform and the inability to download or upload files in the Copy, Space and Service modules, causing disruption. 12:33pm EDT additional customers reported the issue, and all customers were notified of the Severity 2 via status page. At 2:34pm EDT internal teams began to restart dependent services which resolved the issue, and the status page was set to monitoring. As no additional reports were received and customers began to confirm resolution, the status page was marked as resolved at 5:24pm EDT.   

  

Total Duration of Event: 

2 hrs 28 mins 

 

Root Cause Analysis: 

FTP server was not responding. 

 

Preventative Action:  

There were no alerts when this service went down. Internal teams have created a ticket for research and will put processes in place to avoid this in the future.

Posted Oct 27, 2023 - 19:45 UTC

Resolved
As we have not seen further service disruptions after the fix was implemented, we have moved to the Resolved Phase.
A Detailed RCA will be posted in this incident in 10 business days. Please stay subscribed to the page to receive updates automatically.
Posted Oct 23, 2023 - 21:24 UTC
Monitoring
A fix has been implemented. Engineering has identified a dependent service affecting file uploads. Restarting this service seems to have resolved the issue. We are moving into the Monitoring Phase for the next hour.
Posted Oct 23, 2023 - 18:50 UTC
Investigating
We are currently investigating an issue with Copy, Space, Service Requests and the inability to download or upload files. Our Engineering team is currently investigating to determine the cause of the disruption. The next update will be posted at 3pm CST.
Posted Oct 23, 2023 - 16:46 UTC
This incident affected: Eptura Workplace Modules (Space Module, Service Request Module, Copy Module).