Our team has completed the backlog of pending events, and the system is fully functional now.
Posted Jul 17, 2025 - 12:34 UTC
Update
The syncing problem between Microsoft Exchange and Eptura Workplace has been resolved. Our team is actively processing the backlog of events that occurred during this time period. To expedite this process, we have scaled our capacity, and we expect the backlog to be fully processed by the start of business on July 17.
Please note that desk bookings (ME Spaces) in Workplace are not affected. There may be a short delay in syncing your Microsoft and Eptura calendars. We appreciate your understanding and patience as we work to ensure everything is running smoothly.
Posted Jul 16, 2025 - 17:04 UTC
Update
Our Engineering team has identified that the system is working on clearing the backlog of events. As it is taking longer than normal due to sudden influx of events, some delays are expected to continue till the queue is fully cleared.
We shall continue to monitor the situation and post an update by 18:30 US Central Time.
Posted Jul 16, 2025 - 12:21 UTC
Monitoring
The third-party vendor has provided a possible solution, and our team is currently implementing/monitoring the situation. While we do not yet have an estimated time for confirmation, however, we will continue to share updates as we learn more.
We apologize for any inconvenience and are committed to restoring full functionality as soon as possible. Thank you for your understanding and patience. Our next update will be provided at 6:30 AM CST.
Posted Jul 16, 2025 - 07:30 UTC
Update
Our third-party vendor’s Office 365 continues to investigate.
We are actively working with the vendor to identify the root cause and restore functionality. While we do not yet have an estimated time for resolution, we will continue to share updates as we learn more.
The next update will be 1 AM CST.
We apologize for the inconvenience and appreciate your continued patience as we work to resolve this issue.
Posted Jul 15, 2025 - 23:59 UTC
Update
Our third-party vendor’s Office 365 integration is still under investigation. At this time, update messages (webhooks) from Microsoft are not reaching the Eptura Calendar service, preventing new calendar events and updates from syncing.
We are actively working with the vendor to identify the root cause and restore functionality. While we do not yet have an estimated time for resolution, we will continue to share updates as we learn more.
We apologize for the inconvenience and appreciate your continued patience as we work to resolve this issue.
Posted Jul 15, 2025 - 18:31 UTC
Investigating
Our third-party vendor's Office 365 Integration has stopped sending update messages (webhooks) to the Eptura Calendar service, causing no new calendar events or updates to sync. We have contacted the vendor and are working with them to resolve the issue. We are awaiting an estimated time of resolution and will provide updates as soon as possible. Once the issue is fixed, there may be some delay in syncing your Microsoft and Eptura calendars.
We apologize for any inconvenience and are committed to restoring full functionality as quickly as we can. Thank you for your understanding and patience. Our next update will be provided at 1:00 PM CT
Posted Jul 15, 2025 - 15:40 UTC
This incident affected: Eptura Workplace Modules (Reservation Module).