S2 - All Users are marked as Remote
Incident Report for Eptura Workplace
Postmortem

iOFFICE Detailed Root Cause Analysis – Severity 2 – 05/04/2023

All User Profiles are Marked as Remote

Description:

On May 4, 2023, at approximately 10:23am MST, multiple customers reported issues of the iOffice platform where all users are marked as remote. When trying to update user profile, an error was presented, “Could not get split”. The engineering team was able to identify the issue and released a fix for all customers.

Type of Event:

Performance Degradation

 

Services\Modules Impacted:

Production

 

Timeline:

On May 4, 2023, at approximately 10:23am MST, multiple customers reported issues in iOffice where all users were marked as remote users. When trying to update their user profile, an error was presented, could not get split. At 1:04pm MST, the engineering team had identified the issue. Shortly after, customers were notified, and the Status Page was updated from Investigation to an Identified phase. At approximately 10:25pm, the fix was fixed and implemented. On May 5, 2023, the Status Page was updated from Identified to a Monitoring phase at 6:43am MST. As no additional customers reported this issue the Status Page was updated from Monitoring to Resolved.

 

Total Duration of Event: 12HRS 2MINS

 

Root Cause Analysis:

The engineering team identified the Root Cause in the program and a minor code fix was implemented to correct it.

Preventative Action:

The issue was identified before the new iOffice product release on 05/26/2023. The preventative action is for product and engineering to revisit any known issues during a release and fix or remove the underlying issues that can cause problems after a new product release.

Posted May 12, 2023 - 19:36 UTC

Resolved
This incident has been resolved.
Posted May 05, 2023 - 16:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 05, 2023 - 12:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2023 - 12:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2023 - 00:14 UTC
Update
The issue with All Users are marked as Remote has been identified and our team continues to work on a fix.
Posted May 04, 2023 - 21:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2023 - 19:07 UTC
Update
We are continuing to investigate this issue. We appreciate your patience as we work towards a resolution.
Posted May 04, 2023 - 18:29 UTC
Investigating
We are currently investigating this issue.
Posted May 04, 2023 - 16:22 UTC
This incident affected: System Status and Eptura Workplace Modules (Insights Module).