S1 - Inability to Access Eptura Workplace
Incident Report for Eptura Workplace
Postmortem

Eptura Workplace Detailed Root Cause Analysis | Severity 1 | August 9, 2023  

Inability to Access Eptura Workplace Platform 

Description: 

On August 9, 2023, at approximately 1:54am EST, internal teams and customers support started to receive reports of issues throughout the iOffice platform with inability to access the Eptura Workplace platform. When accessing the platform customers would experience a Bad Gateway error.    

Type of Event: 

Outage 

 

Services\Modules Impacted: 

All Services & Modules 

 

Timeline:  

1:54pm EST – Internal teams and customers have reported the inability to access the Eptura Workplace Platform.  After a short investigation and information gathering internal teams found the issue was caused from a hotfix that was released the same day. 2:09pm EST all customers were notified of the S1 incident via status page. 2:16pm Engineering begins to roll back the hotfix and 2:26pm EST, customers are notified that we have identified the issue and we are implementing the fix. 2:34pm EST Engineering confirms that that the rollback is complete, and systems are looking normal again. 2:37pm EST the status page has been updated to a monitoring phase and support begins to verify the resolution with all customers who reported the issue. 4:46pm EST, after confirmation from customers and no additional reports have been submitted to support, the status page was marked as resolved.  

 

Total Duration of Event: 

40 minutes 

 

Remediation: 

To resolve this issue a hotfix was rolled back, and all systems were restored. 

 

Preventative Action:  

Engineering team is working on aligning internal QA when rolling out this specific hotfix.

Posted Aug 14, 2023 - 21:52 UTC

Resolved
This incident has been resolved.
Posted Aug 09, 2023 - 20:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2023 - 18:37 UTC
Identified
The issue has been identified and are implementing the fix for the inability to access Eptura Workplace
Posted Aug 09, 2023 - 18:26 UTC
Update
We are continuing to investigate this issue.
Posted Aug 09, 2023 - 18:11 UTC
Investigating
We are currently investigating an issue with iOffice. We will update you when we have more information.
Posted Aug 09, 2023 - 18:09 UTC
This incident affected: System Status.