S2 - Reservations - floor plan and calendar views not loading existing data and certain workflows are failing
Incident Report for Eptura Workplace
Resolved
We are pleased to inform you that the issue with S2 - Reservations - floor plan and calendar views not loading existing data and certain workflows are failing has been resolved. Our Engineering team has completed the necessary actions and verified that the service is now functioning normally.

A Root Cause Analysis (RCA) will be conducted to understand the incident in detail and will be made available on our Status Page within 10 days.

We wanted to provide an update regarding the hotfix we recently released. During our thorough release testing, we discovered a small issue. After careful consideration, we decided to proceed with the release as planned, as the benefits significantly outweigh the impact of the issue.

Here's what you need to know about the issue’s impact:

For customers using Microsoft Exchange Web service or Google Calendar service, there is a minor issue in the Reservation Center affecting spaces not integrated with Exchange/GCal where the “split multi-day” preference is set to “true.” In this scenario, multi-day events may not split as expected. Rest assured, all other functionalities (creation, edit, delete, and notifications) will work normally as expected.
Our team has already identified the root cause and is developing a solution which will be resolved in our next release.

We appreciate your patience as we continue to enhance the system.
Posted Oct 04, 2024 - 22:35 UTC
Monitoring
We have implemented a solution for the issue affecting Reservations - floor plan and calendar views not loading existing data and certain workflows are failing and are currently monitoring the situation to ensure stability and performance. Our Engineering team is overseeing the process to confirm that the issue has been fully resolved.

Next Update 5:30 PM CST
Posted Oct 04, 2024 - 20:30 UTC
Update
We are committed to keeping you informed about our efforts to resolve the ongoing issue. Our dedicated teams have been working diligently to ensure the upcoming hotfix meets the highest standards of quality, and we're pleased to share that it has now passed our QA testing.

We are now preparing for the release of the hotfix on Thursday, October 3rd at 10 PM CDT. Our QA team will begin comprehensive regression testing starting tomorrow to ensure everything is functioning as expected.

We appreciate your ongoing understanding and support as we strive to deliver a reliable and effective solution.
Posted Sep 27, 2024 - 17:32 UTC
Identified
To ensure we deliver the best experience, our product and QA teams are thoroughly testing the hotfix initially planned for September 24, 2024. They've identified an issue that requires additional attention, so we're taking extra time to make sure everything is perfect. Our teams are working diligently to resolve this and will share an update as soon as possible. We appreciate your understanding and patience.
Posted Sep 25, 2024 - 15:02 UTC
Monitoring
A fix was implemented on the system and we are currently monitoring the situation.
Posted Sep 25, 2024 - 11:30 UTC
Update
Our internal team has developed a fix and is testing the same. Once the testing is completed, it will be rolled out to Production environment.

Next update: 9 AM Central time on Tuesday, September 24, 2024.
Posted Sep 18, 2024 - 14:20 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 9 AM Central Time.
Posted Sep 18, 2024 - 10:19 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 3AM CST
Posted Sep 18, 2024 - 03:57 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 11PM CST
Posted Sep 17, 2024 - 23:14 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 6 PM CST
Posted Sep 17, 2024 - 18:02 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 1 PM CST
Posted Sep 17, 2024 - 13:11 UTC
Update
We are continuing to work on implementing a fix for this issue. Our next update will be at 8 AM CST
Posted Sep 17, 2024 - 08:48 UTC
Update
We are continuing to work on implementing a fix for this issue.
Our next update will be at 4 AM CST
Posted Sep 17, 2024 - 05:15 UTC
Identified
The issue with the Hummingbird Application and the intermittent accessibility issue has been identified and a fix is being implemented. We will post another update at 6:15 CST or sooner.
Posted Sep 16, 2024 - 19:14 UTC
Investigating
Our engineering team have diligently work through the weekend and continue to investigate the intermittent accessibility issue for the Hummingbird Application. We will be moving back into an investigation phase and will continue to keep you updated. We appreciate your patience as we work through this.

Next Update: 1 PM MDT
Posted Sep 16, 2024 - 15:04 UTC
Update
We are continuing to monitor the accessibility issue with the Hummingbird Application for some users throughout the day. We will be updating on Monday the 16th at 9 am MST
Posted Sep 14, 2024 - 01:16 UTC
Update
We are continuing to monitor the accessibility issue with the Hummingbird Application for some users throughout the day.

Next Update: 5 PM CST
Posted Sep 13, 2024 - 18:04 UTC
Update
We are continuing to monitor the accessibility issue with the Hummingbird Application for some users throughout the morning.

Next Update: 1 PM CST
Posted Sep 13, 2024 - 13:05 UTC
Update
We will continue to monitor the accessibility issue with the Hummingbird Application for some users through out the evening. Meanwhile all reservation workflows are working as expected.

Next Update: 8 AM CST
Posted Sep 12, 2024 - 22:04 UTC
Update
We are pleased to inform you that the check-in errors previously identified have been largely resolved. Most functionality has been restored. However, we are aware of some residual issues with the Hummingbird Application that may still be affecting a few users. Our Support teams are actively monitoring the situation and working to resolve these remaining problems to ensure full stability.

Next Update: 5pm CST
Posted Sep 12, 2024 - 18:00 UTC
Update
Our support team will continue to monitor check-in errors throughout the day.

Next update: 1 PM CST
Posted Sep 12, 2024 - 13:00 UTC
Update
Our Support team is continuing to diligently monitor the check-in errors. We will maintain close observation overnight to ensure stability.

Next update: 8 AM CST
Posted Sep 12, 2024 - 00:55 UTC
Update
We are happy to report that the check-in errors previously identified have been successfully resolved without the need for a code release. Expected functionality has been restored. Our Support teams are diligently monitoring the situation to ensure continued stability.

Next update: 8 PM CST
Posted Sep 11, 2024 - 21:22 UTC
Update
We appreciate patience as we actively address the recent challenges with the Workplace Reservations feature during check-ins.

Following the update on September 5, we encountered some performance issues with the Reservations feature and the Hummingbird app. To ensure service continuity, we have reverted to the previous software version. This action has successfully resolved the errors related to Reservation floor plans and connectivity issues with the Hummingbird app.

Our team is committed to fully resolving the check-in errors and restoring optimal functionality to the Reservations feature.. We are making steady progress and will continue to keep you informed with the latest updates as we enhance the system.

Should you encounter any further difficulties, please do not hesitate to reach out to our support team for immediate assistance. We value your cooperation and are here to support you. Thank you.

Next update - 4 PM CDT
Posted Sep 11, 2024 - 17:06 UTC
Update
Observation continues for the errors. Our team is investigating the issue and we will keep you updated on the progress.

Next update - 1 PM CDT
Posted Sep 11, 2024 - 14:03 UTC
Update
During our detailed testing of the application, we have noticed that floor plan and calendar views are now working fine, however we are still observing errors during checking into reservation. Our team is investigating the issue and we will keep you updated on the progress.

Next update - 9 AM CDT
Posted Sep 11, 2024 - 10:05 UTC
Monitoring
Our team has completed the roll back of the recent release and have also completed the sanity testing. The functionality should be restored now, and we are closely monitoring the same.

Next update 5:30 AM CDT
Posted Sep 11, 2024 - 09:21 UTC
Update
The rollback is currently still in progress.
We will provide another by 4AM CDT.
Posted Sep 11, 2024 - 05:10 UTC
Update
We are continuing to investigate a rollback and fix for this issue.
Please note that this issue may also impact check-ins.

Our next update will be by 12AM CDT.
Posted Sep 11, 2024 - 01:08 UTC
Identified
Our Engineering team has identified the root cause of the disruption affecting Reservations, where floor plan and calendar views are not loading existing data and some workflows are failing.

We are actively working on a solution to restore full functionality. Part of this resolution involves rolling back the recent release deployed on September 5th.

We are closely monitoring the situation and will provide the next update by 6 PM CST.

Thank you for your continued patience as we work to resolve the issue.
Posted Sep 10, 2024 - 19:44 UTC
Update
We are currently investigating an issue with Reservations - floor plan and calendar views not loading existing data and certain workflows are failing.

Our Engineering team is actively working to determine the root cause of the disruption and assess its impact.

We will provide our next update by 6:23pm CST.

Thank you for your patience as we work to resolve this issue.
Posted Sep 10, 2024 - 19:24 UTC
Investigating
We are currently investigating an issue with Eptura Workplace. We will update you when we have more information.
Posted Sep 10, 2024 - 19:20 UTC
This incident affected: Apps (Hummingbird App) and Eptura Workplace Modules (Reservation Module).