We are pleased to inform you that the issue with Workplace not being accessible has been resolved. Our Engineering team has completed the necessary actions and verified that the service is now functioning normally.
A Root Cause Analysis (RCA) will be conducted to understand the incident in detail and will be made available on our Status Page within 10 days.
Thank you for your patience and cooperation throughout this process. If you have any further questions or concerns, please feel free to reach out
Posted Apr 03, 2025 - 23:24 UTC
Monitoring
The issue has been fixed. We shall continue to monitor the situation for next 8 hours.
Posted Apr 03, 2025 - 09:03 UTC
Update
Eptura Workplace application is not accessible. We are currently investigating the issue.
Posted Apr 03, 2025 - 08:30 UTC
Investigating
We are currently investigating an issue with Eptura Workplace. We will update you when we have more information.