We have received reports that some users are experiencing security notifications when logging in to their Eptura Workplace site using Firefox or Chrome. Our teams are actively working to resolve this, and we are in close communication with Google to ensure the notice is removed as soon as possible.
While we understand that the notice can be disruptive, rest assured that proceeding through the alert is safe. If you prefer not to see the notice, we recommend using another browser, such as Microsoft Edge, for a smoother experience.
Thank you for your patience and understanding. We appreciate your cooperation and are committed to providing you with the best possible service.
Posted Dec 11, 2024 - 19:31 UTC
Update
We have received reports that some users are experiencing security notifications when trying to log in to their Eptura Workplace site using Firefox or Chrome browsers. Our Security and Cloud Operations teams are actively working to resolve this, and we are in communication with Google to address the matter. Thank you for your understanding and cooperation.
Posted Dec 10, 2024 - 21:39 UTC
Investigating
We have received reports that some users are experiencing security notifications when trying to log in to their Eptura Workplace site using Firefox or Chrome browsers. Our Security and Cloud Operations teams are currently investigating this. Thank you for your understanding and cooperation.