We are investigating an issue with Eptura Workplace

Incident Report for Eptura Workplace

Resolved

Please disregard this alert as it was posted by mistake. All sites are working as expected. We apologize for any inconvenience.
Posted Jun 10, 2025 - 20:31 UTC

Investigating

We are currently investigating an issue with Eptura Workplace. We will update you when we have more information.
Posted Jun 10, 2025 - 19:53 UTC